Wednesday, January 25, 2012

Eclipse IDE and the ADT: Missing requirement: Error

Setting up my laptop for developing Android applications under Ubuntu, I was faced with the error message:

  Missing requirement: Shared profile ( requires 'org.maven.ide.eclipse []' but it could not be found
This was during the installation of the Android Development Tools (ADT) under eclipse. When I googled the problem, it turned out to be something related to "administrative" privileges (under Windows platform), and seems to be related to Indigo version of eclipse.

Anyway, I figured that if it's something related to "administrative privileges", then I might solve this by launching the eclipse in su mode. Alt+F2 got me the command dialog, where:

gksudo eclipse

Setting up the ADT using the google repository as described in the official document was a matter of waiting for the download to complete, after that.

No comments:

Post a Comment